{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-18905 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2019-18905 is a medium-severity vulnerability in SUSE Linux Enterprise Server 12, published on 3 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-18905 and fix it if it is affected.\n\nWhat it is: CVE-2019-18905 is a medium-severity vulnerability in SUSE Linux Enterprise Server 12, published on 3 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-18905 in the wild and no public exploit code.\n\nAffected product: SUSE Linux Enterprise Server 12. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-18905/ (Markdown: https://insights.sbomify.com/CVE-2019-18905/index.md)","id":"CVE-2019-18905","markdown":"https://insights.sbomify.com/CVE-2019-18905/index.md","name":"CVE-2019-18905","record":{"aliases":["GHSA-fp46-x6qh-pvgg","SUSE-SU-2020:1296-1","openSUSE-SU-2020:0676-1","openSUSE-SU-2024:10642-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"SUSE Linux autoyast","requires_auth":"none","summary":"Attackers can bypass GPG key verification during image creation via deprecated autoyast functionality, enabling man-in-the-middle attacks on SUSE Linux Enterprise Server.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"autoyast2","vendor":"opensuse"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"A Insufficient Verification of Data Authenticity vulnerability in autoyast2 of SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Server 15 allows remote attackers to MITM connections when deprecated and unused functionality of autoyast is used to create images. This issue affects: SUSE Linux Enterprise Server 12 autoyast2 version 4.1.9-3.9.1 and prior versions. SUSE Linux Enterprise Server 15 autoyast2 version 4.0.70-3.20.1 and prior versions.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP1","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deprecated functionality in autoyast2 automatically imports gpg keys without checking them","id":"CVE-2019-18905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"cryptctl: client side password hashing is equivalent to clear text password storage","id":"CVE-2019-18906"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP1","fixed":["4.1.15-3.13.1"],"introduced":["0"],"last_affected":[],"package":"autoyast2","purl":"pkg:rpm/suse/autoyast2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP1","source":"SUSE-SU-2020:1296-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["4.1.15-lp151.2.12.1"],"introduced":["0"],"last_affected":[],"package":"autoyast2","purl":"pkg:rpm/opensuse/autoyast2\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:0676-1"}],"prev":{"headline":"Migrations requests can cause DoS on rmt","id":"CVE-2019-18904"},"products":["SUSE Linux Enterprise Server 12","SUSE Linux Enterprise Server 15"],"published":"2020-04-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["SUSE"]},"summary":"Attackers can bypass GPG key verification during image creation via deprecated autoyast functionality, enabling man-in-the-middle attacks on SUSE Linux Enterprise Server.","url":"https://insights.sbomify.com/CVE-2019-18905/"}