# CVE-2019-18954: Pomelo allows external control of critical state data

> Attackers can corrupt internal state and execute arbitrary code by overwriting critical attributes via malicious user input in Pomelo game servers.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4x6v-rwh4-55jw

## What is CVE-2019-18954?

CVE-2019-18954 is a medium-severity vulnerability in n/a, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pomelo v2.2.5 allows external control of critical state data. A malicious user input can corrupt arbitrary methods and attributes in template/game-server/app/servers/connector/handler/entryHandler.js because certain internal attributes can be overwritten via a conflicting name. Hence, a malicious attacker can manipulate internal attributes by adding additional attributes to user input.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2019-18954?

2 open source packages ship an affected version, including pomelo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pomelo` | npm | All versions | 2.2.7 |
| `pomelo` | npm | All versions | 2.2.7 |

Products: Netease Pomelo.

## How do I fix CVE-2019-18954?

Upgrade pomelo to 2.2.7 or later.

## Is CVE-2019-18954 being exploited?

There is no known exploitation of CVE-2019-18954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18954 and fix it if it is affected.

What it is: CVE-2019-18954 is a medium-severity vulnerability in n/a, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18954 in the wild and no public exploit code.

Affected packages and fixed versions:
- pomelo (npm): affected all versions; fixed in 2.2.7
- pomelo (npm): affected all versions; fixed in 2.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18954/ (Markdown: https://insights.sbomify.com/CVE-2019-18954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18954
- OSV: https://osv.dev/vulnerability/CVE-2019-18954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18954/
Summaries are generated and may contain mistakes; the official description above is the record.
