{"answers":{"affected":"2 open source packages ship an affected version, including rack-cors. It affects 3 products.","exploited":"There is no known exploitation of CVE-2019-18978 in the wild and no public exploit code.","fix":"Upgrade rack-cors to 1.0.4 or later.","what":"CVE-2019-18978 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 14 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-18978 and fix it if it is affected.\n\nWhat it is: CVE-2019-18978 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 14 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-18978 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rack-cors (RubyGems): affected all versions; fixed in 1.0.4\n- rack-cors (RubyGems): affected all versions; fixed in 1.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-18978/ (Markdown: https://insights.sbomify.com/CVE-2019-18978/index.md)","id":"CVE-2019-18978","markdown":"https://insights.sbomify.com/CVE-2019-18978/index.md","name":"CVE-2019-18978","record":{"aliases":["DEBIAN-CVE-2019-18978","DLA-2096-1","DLA-2389-1","DSA-4918-1","GHSA-pf8f-w267-mq2h","UBUNTU-CVE-2019-18978","USN-4571-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby CORS middleware","requires_auth":"none","summary":"Attackers can use directory traversal to access private resources in applications using the rack-cors Ruby gem.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"rack-cors","vendor":"rack-cors_project"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"An issue was discovered in the rack-cors (aka Rack CORS Middleware) gem before 1.0.4 for Ruby. It allows ../ directory traversal to access private resources because resource matching does not ensure that pathnames are in a canonical format.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The rack-cors rubygem may allow directory traveral","id":"CVE-2019-18978","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux"],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":6,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2019-18979"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"rack-cors","purl":null,"source":"GHSA-pf8f-w267-mq2h"},{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"rack-cors","purl":"pkg:gem/rack-cors","source":"GHSA-pf8f-w267-mq2h"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2019-18976"},"products":["n/a"],"published":"2019-11-14","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can use directory traversal to access private resources in applications using the rack-cors Ruby gem.","url":"https://insights.sbomify.com/CVE-2019-18978/"}