# CVE-2019-18978: The rack-cors rubygem may allow directory traveral

> Attackers can use directory traversal to access private resources in applications using the rack-cors Ruby gem.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-18978, DLA-2096-1, DLA-2389-1, DSA-4918-1, GHSA-pf8f-w267-mq2h, UBUNTU-CVE-2019-18978, USN-4571-1

## What is CVE-2019-18978?

CVE-2019-18978 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 14 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the rack-cors (aka Rack CORS Middleware) gem before 1.0.4 for Ruby. It allows ../ directory traversal to access private resources because resource matching does not ensure that pathnames are in a canonical format.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-18978?

2 open source packages ship an affected version, including rack-cors. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack-cors` | RubyGems | All versions | 1.0.4 |
| `rack-cors` | RubyGems | All versions | 1.0.4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Rack-Cors Project Rack-Cors.

## How do I fix CVE-2019-18978?

Upgrade rack-cors to 1.0.4 or later.

## Is CVE-2019-18978 being exploited?

There is no known exploitation of CVE-2019-18978 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18978 and fix it if it is affected.

What it is: CVE-2019-18978 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 14 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18978 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack-cors (RubyGems): affected all versions; fixed in 1.0.4
- rack-cors (RubyGems): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18978/ (Markdown: https://insights.sbomify.com/CVE-2019-18978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18978
- OSV: https://osv.dev/vulnerability/CVE-2019-18978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18978/
Summaries are generated and may contain mistakes; the official description above is the record.
