# CVE-2019-18982: Pimcore Cross-site Scripting (XSS) vulnerability

> Attackers can execute arbitrary scripts in the Email Log preview window due to missing Content-Security-Policy headers in Pimcore.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m4x3-xmjv-r778

## What is CVE-2019-18982?

CVE-2019-18982 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 15 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

bundles/AdminBundle/Controller/Admin/EmailController.php in Pimcore before 6.3.0 allows script execution in the Email Log preview window because of the lack of a Content-Security-Policy header.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-18982?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 6.3.0 |
| `pimcore/pimcore` | Packagist | All versions | 6.3.0 |

Products: Pimcore Pimcore.

## How do I fix CVE-2019-18982?

Upgrade pimcore/pimcore to 6.3.0 or later.

## Is CVE-2019-18982 being exploited?

There is no known exploitation of CVE-2019-18982 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18982 and fix it if it is affected.

What it is: CVE-2019-18982 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 15 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-18982 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 6.3.0
- pimcore/pimcore (Packagist): affected all versions; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18982/ (Markdown: https://insights.sbomify.com/CVE-2019-18982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18982
- OSV: https://osv.dev/vulnerability/CVE-2019-18982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18982/
Summaries are generated and may contain mistakes; the official description above is the record.
