# CVE-2019-19010: Eval injection in Supybot/Limnoria

> Remote attackers can execute arbitrary code or disclose information via eval injection in the Math plugin of Limnoria and Supybot IRC bots.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-19010, GHSA-6g88-vr3v-76mf, PYSEC-2019-102

## What is CVE-2019-19010?

CVE-2019-19010 is a critical code injection vulnerability in Fedoraproject Fedora, published on 16 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eval injection in the Math plugin of Limnoria (before 2019.11.09) and Supybot (through 2018-05-09) allows remote unprivileged attackers to disclose information or possibly have unspecified other impact via the calc and icalc IRC commands.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-19010?

3 open source packages ship an affected version, including limnoria. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limnoria` | PyPI | All versions | 2019.11.09 |
| `limnoria` | PyPI | All versions | 2019.11.09 |
| `limnoria` | PyPI | All versions | 2019.11.09 |

Products: Fedoraproject Fedora, Limnoria Project Limnoria.

## How do I fix CVE-2019-19010?

Upgrade limnoria to 2019.11.09 or later.

## Is CVE-2019-19010 being exploited?

There is no known exploitation of CVE-2019-19010 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19010 and fix it if it is affected.

What it is: CVE-2019-19010 is a critical code injection vulnerability in Fedoraproject Fedora, published on 16 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19010 in the wild and no public exploit code.

Affected packages and fixed versions:
- limnoria (PyPI): affected all versions; fixed in 2019.11.09
- limnoria (PyPI): affected all versions; fixed in 2019.11.09
- limnoria (PyPI): affected all versions; fixed in 2019.11.09

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19010/ (Markdown: https://insights.sbomify.com/CVE-2019-19010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19010
- OSV: https://osv.dev/vulnerability/CVE-2019-19010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19010/
Summaries are generated and may contain mistakes; the official description above is the record.
