# CVE-2019-19030: Unauthenticated users can exploit an enumeration vulnerability in Harbor (CVE-2019-19030)

> Unauthenticated API calls in Harbor reveal resource existence via HTTP status codes, allowing attackers to enumerate resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-q9x4-q76f-5h5j, GO-2022-0704

## What is CVE-2019-19030?

CVE-2019-19030 is a medium-severity vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloud Native Computing Foundation Harbor before 1.10.3 and 2.x before 2.0.1 allows resource enumeration because unauthenticated API calls reveal (via the HTTP status code) whether a resource exists.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2019-19030?

5 open source packages ship an affected version, including github.com/goharbor/harbor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/goharbor/harbor` | Go | From 1.7.0 | 1.10.3, 2.0.1+incompatible |
| `github.com/goharbor/harbor` | Go | From 1.7.0 | 1.10.3 |
| `github.com/goharbor/harbor` | Go | From 1.7.0 | 1.10.3 |
| `github.com/goharbor/harbor` | Go | From 2.0.0 | 2.0.1 |
| `github.com/goharbor/harbor` | Go | From 2.0.0 | 2.0.1 |

Products: Linuxfoundation Harbor.

## How do I fix CVE-2019-19030?

Upgrade github.com/goharbor/harbor to a fixed version for your release line: 1.10.3, 2.0.1+incompatible or 2.0.1.

## Is CVE-2019-19030 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-19030 exists.

Public exploit code:

- Exploit for CVE-2019-19030 that affects Harbor versions <1.10.3 and <2.0.1. Can also be used to enumerate and pull public projects from higher versions. (github_poc): https://github.com/shodanwashere/boatcrash

## Other vulnerabilities in n/a

- [CVE-2026-4404](https://insights.sbomify.com/CVE-2026-4404/): Use of hard coded credentials in GoHarbor Harbor (critical 9.4)
- [CVE-2019-19023](https://insights.sbomify.com/CVE-2019-19023/): Privilege Escalation in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2019-19025](https://insights.sbomify.com/CVE-2019-19025/): Cross-site Request Forgery (CSRF) in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2017-17697](https://insights.sbomify.com/CVE-2017-17697/): Server-side request forgery in n/a (high 8.6)
- [CVE-2022-31666](https://insights.sbomify.com/CVE-2022-31666/): Harbor fails to validate user permissions while Viewing, updating and deleting Webhook policies (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19030 and fix it if it is affected.

What it is: CVE-2019-19030 is a medium-severity vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-19030 exists.

Affected packages and fixed versions:
- github.com/goharbor/harbor (Go): affected from 1.7.0; fixed in 1.10.3, 2.0.1+incompatible
- github.com/goharbor/harbor (Go): affected from 1.7.0; fixed in 1.10.3
- github.com/goharbor/harbor (Go): affected from 1.7.0; fixed in 1.10.3
- github.com/goharbor/harbor (Go): affected from 2.0.0; fixed in 2.0.1
- github.com/goharbor/harbor (Go): affected from 2.0.0; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19030/ (Markdown: https://insights.sbomify.com/CVE-2019-19030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19030
- OSV: https://osv.dev/vulnerability/CVE-2019-19030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19030/
Summaries are generated and may contain mistakes; the official description above is the record.
