# CVE-2019-19210: Dolibarr ERP and CRM contain XSS Vulnerability

> Attackers can execute arbitrary scripts in victim browsers by uploading HTML documents that are served with incorrect content types.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-87r3-4gc8-f897, UBUNTU-CVE-2019-19210

## What is CVE-2019-19210?

CVE-2019-19210 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Dolibarr ERP/CRM before 10.0.3 allows XSS because uploaded HTML documents are served as text/html despite being renamed to .noexe files.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-19210?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 10.0.3 |
| `dolibarr/dolibarr` | Packagist | All versions | 10.0.3 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2019-19210?

Upgrade dolibarr/dolibarr to 10.0.3 or later.

## Is CVE-2019-19210 being exploited?

There is no known exploitation of CVE-2019-19210 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19210 and fix it if it is affected.

What it is: CVE-2019-19210 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-19210 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 10.0.3
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 10.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19210/ (Markdown: https://insights.sbomify.com/CVE-2019-19210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19210
- OSV: https://osv.dev/vulnerability/CVE-2019-19210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19210/
Summaries are generated and may contain mistakes; the official description above is the record.
