{"answers":{"affected":"2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-19211 in the wild and no public exploit code.","fix":"Upgrade dolibarr/dolibarr to 10.0.3 or later.","what":"CVE-2019-19211 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-19211 and fix it if it is affected.\n\nWhat it is: CVE-2019-19211 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-19211 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 10.0.3\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 10.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-19211/ (Markdown: https://insights.sbomify.com/CVE-2019-19211/index.md)","id":"CVE-2019-19211","markdown":"https://insights.sbomify.com/CVE-2019-19211/index.md","name":"CVE-2019-19211","record":{"aliases":["GHSA-gfhf-2xr5-2fvw","UBUNTU-CVE-2019-19211"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the context of other users via insufficient filtering in the user card interface.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dolibarr","vendor":"dolibarr"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Dolibarr ERP/CRM before 10.0.3 has an Insufficient Filtering issue that can lead to user/card.php XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dolibarr ERP and CRM contain XSS Vulnerability","id":"CVE-2019-19211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php","id":"CVE-2019-19212"},"packages":[{"ecosystem":"Packagist","fixed":["10.0.3"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-gfhf-2xr5-2fvw"},{"ecosystem":"Packagist","fixed":["10.0.3"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-gfhf-2xr5-2fvw"}],"prev":{"headline":"Dolibarr ERP and CRM contain XSS Vulnerability","id":"CVE-2019-19210"},"products":["n/a"],"published":"2020-03-16","related":[{"cvss_score":9.8,"headline":"Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php","id":"CVE-2019-19212","kev_date_added":null,"published":"2020-03-16"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection via the integer parameters qty and value_unit","id":"CVE-2018-16809","kev_date_added":null,"published":"2019-03-07"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability","id":"CVE-2018-10094","kev_date_added":null,"published":"2018-05-22"},{"cvss_score":9.8,"headline":"Dolibarr SQL Injection vulnerability","id":"CVE-2018-9019","kev_date_added":null,"published":"2018-05-22"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in admin/menus/edit.php","id":"CVE-2017-14238","kev_date_added":null,"published":"2017-09-11"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in don/list.php","id":"CVE-2017-14242","kev_date_added":null,"published":"2017-09-11"},{"cvss_score":9.8,"headline":"Dolibarr ERP and CRM SQLi","id":"CVE-2017-9435","kev_date_added":null,"published":"2017-06-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in the context of other users via insufficient filtering in the user card interface.","url":"https://insights.sbomify.com/CVE-2019-19211/"}