# CVE-2019-19274: typed-ast Out-of-bounds Read

> An out-of-bounds read in typed_ast allows attackers to crash the Python interpreter by providing malicious source code for parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-19274, GHSA-m3jw-62m7-jjcm, PYSEC-2019-130, UBUNTU-CVE-2019-19274

## What is CVE-2019-19274?

CVE-2019-19274 is a high-severity denial of service vulnerability in n/a, published on 26 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

typed_ast 1.3.0 and 1.3.1 has a handle_keywordonly_args out-of-bounds read. An attacker with the ability to cause a Python interpreter to parse Python source (but not necessarily execute it) may be able to crash the interpreter process. This could be a concern, for example, in a web-based service that parses (but does not execute) Python code. (This issue also affected certain Python 3.8.0-alpha prereleases.)

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-19274?

3 open source packages ship an affected version, including typed-ast. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typed-ast` | PyPI | All versions | 1.3.2 |
| `typed-ast` | PyPI | From 1.3.0 | 1.3.2 |
| `typed-ast` | PyPI | From 1.3.0 | 1.3.2 |

Products: Python Typed Ast.

## How do I fix CVE-2019-19274?

Upgrade typed-ast to 1.3.2 or later.

## Is CVE-2019-19274 being exploited?

There is no known exploitation of CVE-2019-19274 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19275](https://insights.sbomify.com/CVE-2019-19275/): typed-ast Out-of-bounds Read (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19274 and fix it if it is affected.

What it is: CVE-2019-19274 is a high-severity denial of service vulnerability in n/a, published on 26 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19274 in the wild and no public exploit code.

Affected packages and fixed versions:
- typed-ast (PyPI): affected all versions; fixed in 1.3.2
- typed-ast (PyPI): affected from 1.3.0; fixed in 1.3.2
- typed-ast (PyPI): affected from 1.3.0; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19274/ (Markdown: https://insights.sbomify.com/CVE-2019-19274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19274
- OSV: https://osv.dev/vulnerability/CVE-2019-19274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19274/
Summaries are generated and may contain mistakes; the official description above is the record.
