# CVE-2019-19316: Use of a Broken or Risky Cryptographic Algorithm in Terraform

> Attackers can intercept Terraform state and SAS tokens transmitted over cleartext HTTP when using the Azure backend.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4rvg-555h-r626, GHSA-h3p9-wrgx-82cm, GO-2022-0839, SUSE-SU-2020:0320-1, openSUSE-SU-2024:11429-1

## What is CVE-2019-19316?

CVE-2019-19316 is a high-severity vulnerability in n/a, published on 2 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When using the Azure backend with a shared access signature (SAS), Terraform versions prior to 0.12.17 may transmit the token and state snapshot using cleartext HTTP.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2019-19316?

3 open source packages ship an affected version, including github.com/hashicorp/terraform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/terraform` | Go | All versions | 0.12.17 |
| `github.com/hashicorp/terraform` | Go | All versions | 0.12.17 |
| `github.com/hashicorp/terraform` | Go | All versions | 0.12.17 |
| `terraform` | SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 0.12.19-3.6.1 |
| `terraform` | openSUSE:Tumbleweed | All versions | 0.14.10-1.12 |

Products: Hashicorp Terraform.

## How do I fix CVE-2019-19316?

Upgrade github.com/hashicorp/terraform to 0.12.17 or later.

## Is CVE-2019-19316 being exploited?

There is no known exploitation of CVE-2019-19316 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-9057](https://insights.sbomify.com/CVE-2018-9057/): HashiCorp Terraform Amazon Web Services (AWS) uses an insecure PRNG (critical 9.8)
- [CVE-2021-36230](https://insights.sbomify.com/CVE-2021-36230/): Missing authorization in n/a (high 8.8)
- [CVE-2023-4782](https://insights.sbomify.com/CVE-2023-4782/): Terraform Allows Arbitrary File Write During Init Operation (medium 6.3)
- [CVE-2025-13432](https://insights.sbomify.com/CVE-2025-13432/): Terraform Enterprise state versions can be created by users with specific permissions without sufficient write access (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19316 and fix it if it is affected.

What it is: CVE-2019-19316 is a high-severity vulnerability in n/a, published on 2 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19316 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/terraform (Go): affected all versions; fixed in 0.12.17
- github.com/hashicorp/terraform (Go): affected all versions; fixed in 0.12.17
- github.com/hashicorp/terraform (Go): affected all versions; fixed in 0.12.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19316/ (Markdown: https://insights.sbomify.com/CVE-2019-19316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19316
- OSV: https://osv.dev/vulnerability/CVE-2019-19316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19316/
Summaries are generated and may contain mistakes; the official description above is the record.
