# CVE-2019-19325: Reflected XSS in SilverStripe

> Reflected XSS in SilverStripe login and custom forms allows attackers to inject scripts, potentially stealing user credentials or sensitive data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qvrv-2x7x-78x2

## What is CVE-2019-19325?

CVE-2019-19325 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 17 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SilverStripe through 4.4.x before 4.4.5 and 4.5.x before 4.5.2 allows Reflected XSS on the login form and custom forms. Silverstripe Forms allow malicious HTML or JavaScript to be inserted through non-scalar FormField attributes, which allows performing XSS (Cross-Site Scripting) on some forms built with user input (Request data). This can lead to phishing attempts to obtain a user's credentials or other sensitive user input.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-19325?

4 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.4.5 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.4.5 |
| `silverstripe/framework` | Packagist | From 4.5.0 | 4.5.2 |
| `silverstripe/framework` | Packagist | From 4.5.0 | 4.5.2 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-19325?

Upgrade silverstripe/framework to a fixed version for your release line: 4.4.5 or 4.5.2.

## Is CVE-2019-19325 being exploited?

There is no known exploitation of CVE-2019-19325 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19325 and fix it if it is affected.

What it is: CVE-2019-19325 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 17 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-19325 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.4.5
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.4.5
- silverstripe/framework (Packagist): affected from 4.5.0; fixed in 4.5.2
- silverstripe/framework (Packagist): affected from 4.5.0; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19325/ (Markdown: https://insights.sbomify.com/CVE-2019-19325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19325
- OSV: https://osv.dev/vulnerability/CVE-2019-19325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19325/
Summaries are generated and may contain mistakes; the official description above is the record.
