# CVE-2019-19326: SilverStripe Web Cache Poisoning through HTTPRequestBuilder

> Attackers can poison web caches in Silverstripe CMS by manipulating specific headers, causing malicious responses to be served to other users.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-q9ff-3q93-fm8m

## What is CVE-2019-19326?

CVE-2019-19326 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Silverstripe CMS sites through 4.4.4 which have opted into HTTP Cache Headers on responses served by the framework's HTTP layer can be vulnerable to web cache poisoning. Through modifying the X-Original-Url and X-HTTP-Method-Override headers, responses with malicious HTTP headers can return unexpected responses to other consumers of this cached response. Most other headers associated with web cache poisoning are already disabled through request hostname forgery whitelists.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2019-19326?

6 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 3.0.0 | 3.7.5 |
| `silverstripe/framework` | Packagist | From 3.0.0 | 3.7.5 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.4.7 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.4.7 |
| `silverstripe/framework` | Packagist | From 4.5.0 | 4.5.4 |
| `silverstripe/framework` | Packagist | From 4.5.0 | 4.5.4 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-19326?

Upgrade silverstripe/framework to a fixed version for your release line: 3.7.5, 4.4.7 or 4.5.4.

## Is CVE-2019-19326 being exploited?

There is no known exploitation of CVE-2019-19326 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19326 and fix it if it is affected.

What it is: CVE-2019-19326 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19326 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 3.0.0; fixed in 3.7.5
- silverstripe/framework (Packagist): affected from 3.0.0; fixed in 3.7.5
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.4.7
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.4.7
- silverstripe/framework (Packagist): affected from 4.5.0; fixed in 4.5.4
- silverstripe/framework (Packagist): affected from 4.5.0; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19326/ (Markdown: https://insights.sbomify.com/CVE-2019-19326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19326
- OSV: https://osv.dev/vulnerability/CVE-2019-19326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19326/
Summaries are generated and may contain mistakes; the official description above is the record.
