CVE-2019-19394 Cross-site scripting in n/a
Cross-site scripting vulnerability in CFEngine Enterprise allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2019-19394?
CVE-2019-19394 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Northern.tech CFEngine Enterprise before 3.10.7, 3.11.x and 3.12.x before 3.12.3, 3.13.x, and 3.14.x allows XSS. This is fixed in 3.10.7, 3.12.3, and 3.15.0.
Weakness: CWE-79
Which versions are affected by CVE-2019-19394?
It affects 1 product.
Products include Northern.tech Cfengine.
How do I fix CVE-2019-19394?
No fix has been published for CVE-2019-19394 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-19394 being exploited?
There is no known exploitation of CVE-2019-19394 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-qm5p-2mv2-7jv5.