# CVE-2019-19507: Validation bypass is possible in Json Pattern Validator

> Attackers can bypass type validation in the jpv library by overwriting internal attributes, allowing crafted payloads to evade security checks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rh46-3fgc-mvrf

## What is CVE-2019-19507?

CVE-2019-19507 is a medium-severity vulnerability in n/a, published on 2 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In jpv (aka Json Pattern Validator) before 2.1.1, compareCommon() can be bypassed because certain internal attributes can be overwritten via a conflicting name, as demonstrated by 'constructor': {'name':'Array'}. This affects validate(). Hence, a crafted payload can overwrite this builtin attribute to manipulate the type detection result.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2019-19507?

2 open source packages ship an affected version, including jpv. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jpv` | npm | All versions | 2.1.1 |
| `jpv` | npm | All versions | 2.1.1 |

Products: Json Pattern Validator Project Json Pattern Validator.

## How do I fix CVE-2019-19507?

Upgrade jpv to 2.1.1 or later.

## Is CVE-2019-19507 being exploited?

There is no known exploitation of CVE-2019-19507 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-17479](https://insights.sbomify.com/CVE-2020-17479/): Validation bypass in jpv (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19507 and fix it if it is affected.

What it is: CVE-2019-19507 is a medium-severity vulnerability in n/a, published on 2 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19507 in the wild and no public exploit code.

Affected packages and fixed versions:
- jpv (npm): affected all versions; fixed in 2.1.1
- jpv (npm): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19507/ (Markdown: https://insights.sbomify.com/CVE-2019-19507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19507
- OSV: https://osv.dev/vulnerability/CVE-2019-19507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19507/
Summaries are generated and may contain mistakes; the official description above is the record.
