{"answers":{"affected":"3 open source packages ship an affected version, including validators. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-19588 in the wild and no public exploit code.","fix":"Upgrade validators to 0.12.6 or later.","what":"CVE-2019-19588 is a high-severity denial of service vulnerability in n/a, published on 5 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-19588 and fix it if it is affected.\n\nWhat it is: CVE-2019-19588 is a high-severity denial of service vulnerability in n/a, published on 5 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-19588 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- validators (PyPI): affected from 0.12.2; fixed in 0.12.6\n- validators (PyPI): affected from 0.12.2; fixed in 0.12.6\n- validators (PyPI): affected from 0.12.2; fixed in 0.12.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-19588/ (Markdown: https://insights.sbomify.com/CVE-2019-19588/index.md)","id":"CVE-2019-19588","markdown":"https://insights.sbomify.com/CVE-2019-19588/index.md","name":"CVE-2019-19588","record":{"aliases":["GHSA-5qcg-w2cc-xffw","PYSEC-2019-134","openSUSE-SU-2024:11278-1","openSUSE-SU-2024:13811-1","openSUSE-SU-2026:12046-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python validators library","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering an infinite loop in the Python validators library via a crafted domain string.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"validators","vendor":"validators_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uncontrolled resource consumption in validators Python package","id":"CVE-2019-19588","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":5,"n_references":1,"next":{"headline":"File upload in n/a","id":"CVE-2019-19589"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.6"],"introduced":["0.12.2"],"last_affected":[],"package":"validators","purl":null,"source":"GHSA-5qcg-w2cc-xffw"},{"ecosystem":"PyPI","fixed":["0.12.6"],"introduced":["0.12.2"],"last_affected":[],"package":"validators","purl":"pkg:pypi/validators","source":"GHSA-5qcg-w2cc-xffw"},{"ecosystem":"PyPI","fixed":["0.12.6"],"introduced":["0.12.2"],"last_affected":[],"package":"validators","purl":"pkg:pypi/validators","source":"PYSEC-2019-134"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.24.0-1.2"],"introduced":["0"],"last_affected":[],"package":"python-validators","purl":"pkg:rpm/opensuse/python-validators\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13811-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.35.0-1.4"],"introduced":["0"],"last_affected":[],"package":"python-validators","purl":"pkg:rpm/opensuse/python-validators\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12046-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-19587"},"products":["n/a"],"published":"2019-12-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by triggering an infinite loop in the Python validators library via a crafted domain string.","url":"https://insights.sbomify.com/CVE-2019-19588/"}