CVE-2019-19609 Command Injection in strapi

High 7.2 Published Updated

Attackers can execute arbitrary shell commands via unsanitized plugin names in the Strapi Admin panel, leading to remote code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-19609?

CVE-2019-19609 is a high-severity command injection vulnerability in n/a, published on 5 Dec 2019. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.

Weakness: CWE-78

Which versions are affected by CVE-2019-19609?

2 open source packages ship an affected version, including strapi. It affects 1 product.

PackageAffectedFixed in
strapi npmAll versions3.0.0-beta.17.8
strapi npmAll versions3.0.0-beta.17.8

Products include Strapi Strapi.

How do I fix CVE-2019-19609?

Upgrade strapi to 3.0.0-beta.17.8 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2019-19609 being exploited?

There is no known exploitation of CVE-2019-19609 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry and 7 proofs of concept on GitHub.

Sources

Also known as GHSA-9p2w-rmx4-9mw7.

Is CVE-2019-19609 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free