{"answers":{"affected":"2 open source packages ship an affected version, including strapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-19609 in the wild and no public exploit code.","fix":"Upgrade strapi to 3.0.0-beta.17.8 or later.","what":"CVE-2019-19609 is a high-severity command injection vulnerability in n/a, published on 5 Dec 2019. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-19609 and fix it if it is affected.\n\nWhat it is: CVE-2019-19609 is a high-severity command injection vulnerability in n/a, published on 5 Dec 2019. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-19609 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- strapi (npm): affected all versions; fixed in 3.0.0-beta.17.8\n- strapi (npm): affected all versions; fixed in 3.0.0-beta.17.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-19609/ (Markdown: https://insights.sbomify.com/CVE-2019-19609/index.md)","id":"CVE-2019-19609","markdown":"https://insights.sbomify.com/CVE-2019-19609/index.md","name":"CVE-2019-19609","record":{"aliases":["GHSA-9p2w-rmx4-9mw7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi CMS","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary shell commands via unsanitized plugin names in the Strapi Admin panel, leading to remote code execution.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"strapi","vendor":"strapi"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.","ecosystems":["npm"],"exploits":{"exploitdb":1,"first_seen":"2021-08-29","github_poc":7,"max_poc_stars":9,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-08-29T17:57:08Z","kind":"github_poc","ref":"https://github.com/diego-tella/CVE-2019-19609-EXPLOIT","stars":9,"title":"Exploit for CVE-2019-19609 in Strapi (Remote Code Execution) "},{"date":"2021-08-29T16:18:27Z","kind":"github_poc","ref":"https://github.com/ebadfd/CVE-2019-19609","stars":7,"title":"Strapi Framework Vulnerable to Remote Code Execution  "},{"date":"2022-01-23T05:28:51Z","kind":"github_poc","ref":"https://github.com/glowbase/CVE-2019-19609","stars":2,"title":"Strapi CMS 3.0.0-beta.17.4 - Unauthenticated Remote Code Execution (CVE-2019-18818, CVE-2019-19609)"},{"date":"2021-08-30","kind":"exploitdb","ref":"50238","stars":null,"title":"Strapi 3.0.0-beta.17.7 - Remote Code Execution (RCE) (Authenticated)"},{"date":"2021-08-30T03:05:16Z","kind":"github_poc","ref":"https://github.com/guglia001/CVE-2019-19609","stars":0,"title":"Strapi \u003c= 3.0.0-beta.17.8 authenticated remote code execution"},{"date":"2021-09-11T06:53:33Z","kind":"github_poc","ref":"https://github.com/D3m0nicw0lf/CVE-2019-19609","stars":0,"title":"Strapi  Remote Code Execution"},{"date":"2021-11-27T13:58:18Z","kind":"github_poc","ref":"https://github.com/n000xy/CVE-2019-19609-POC-Python","stars":0,"title":"Strapi Framework, 3.0.0-beta.17.4"},{"date":"2021-12-08T15:38:20Z","kind":"github_poc","ref":"https://github.com/RamPanic/CVE-2019-19609-EXPLOIT","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command Injection in strapi","id":"CVE-2019-19609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Auth bypass in n/a","id":"CVE-2019-19610"},"packages":[{"ecosystem":"npm","fixed":["3.0.0-beta.17.8"],"introduced":["0"],"last_affected":[],"package":"strapi","purl":null,"source":"GHSA-9p2w-rmx4-9mw7"},{"ecosystem":"npm","fixed":["3.0.0-beta.17.8"],"introduced":["0"],"last_affected":[],"package":"strapi","purl":"pkg:npm/strapi","source":"GHSA-9p2w-rmx4-9mw7"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2019-19608"},"products":["n/a"],"published":"2019-12-05","related":[{"cvss_score":7.2,"headline":"Strapi Cleartext Storage of Sensitive Information","id":"CVE-2023-22894","kev_date_added":"2026-10-08","published":"2023-04-19"},{"cvss_score":10,"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621","kev_date_added":null,"published":"2023-04-19"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Strapi","id":"CVE-2022-27263","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Authorization bypass in Strapi","id":"CVE-2020-27664","kev_date_added":null,"published":"2020-10-22"},{"cvss_score":9.8,"headline":"Strapi allows unauthenticated attacker to reset admin password without valid reset token","id":"CVE-2019-18818","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":9.3,"headline":"Strapi Vulnerable to SQL Injection in Content Type Builder","id":"CVE-2026-22599","kev_date_added":null,"published":"2026-05-14"},{"cvss_score":9.2,"headline":"Strapi may leak sensitive data via relational filtering due to lack of query sanitization","id":"CVE-2026-27886","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary shell commands via unsanitized plugin names in the Strapi Admin panel, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2019-19609/"}