CVE-2019-19619 Cross-site Scripting in Documize
Attackers can inject malicious scripts via untrusted Markdown content in Documize, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-19619?
CVE-2019-19619 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
domain/section/markdown/markdown.go in Documize before 3.5.1 mishandles untrusted Markdown content. This was addressed by adding the bluemonday HTML sanitizer to defend against XSS.
Weakness: CWE-79
Which versions are affected by CVE-2019-19619?
3 open source packages ship an affected version, including github.com/documize/community. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/documize/community Go | All versions | 1.76.3-0.20191119114751-a4384210d4d0 |
github.com/documize/community Go | All versions | 3.5.1 |
github.com/documize/community Go | All versions | 3.5.1 |
Products include Documize Documize.
How do I fix CVE-2019-19619?
Upgrade github.com/documize/community to a fixed version for your release line: 1.76.3-0.20191119114751-a4384210d4d0 or 3.5.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-19619 being exploited?
There is no known exploitation of CVE-2019-19619 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-wmwp-pggc-h4mj, GO-2021-0086.