{"answers":{"affected":"3 open source packages ship an affected version, including github.com/documize/community. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-19619 in the wild and no public exploit code.","fix":"Upgrade github.com/documize/community to a fixed version for your release line: 1.76.3-0.20191119114751-a4384210d4d0 or 3.5.1.","what":"CVE-2019-19619 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-19619 and fix it if it is affected.\n\nWhat it is: CVE-2019-19619 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-19619 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/documize/community (Go): affected all versions; fixed in 1.76.3-0.20191119114751-a4384210d4d0\n- github.com/documize/community (Go): affected all versions; fixed in 3.5.1\n- github.com/documize/community (Go): affected all versions; fixed in 3.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-19619/ (Markdown: https://insights.sbomify.com/CVE-2019-19619/index.md)","id":"CVE-2019-19619","markdown":"https://insights.sbomify.com/CVE-2019-19619/index.md","name":"CVE-2019-19619","record":{"aliases":["GHSA-wmwp-pggc-h4mj","GO-2021-0086"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Documize wiki","requires_auth":"none","summary":"Attackers can inject malicious scripts via untrusted Markdown content in Documize, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"documize","vendor":"documize"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"domain/section/markdown/markdown.go in Documize before 3.5.1 mishandles untrusted Markdown content. This was addressed by adding the bluemonday HTML sanitizer to defend against XSS.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Documize","id":"CVE-2019-19619","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":3,"n_references":3,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2019-19620"},"packages":[{"ecosystem":"Go","fixed":["1.76.3-0.20191119114751-a4384210d4d0"],"introduced":["0"],"last_affected":[],"package":"github.com/documize/community","purl":"pkg:golang/github.com/documize/community","source":"GO-2021-0086"},{"ecosystem":"Go","fixed":["3.5.1"],"introduced":["0"],"last_affected":[],"package":"github.com/documize/community","purl":null,"source":"GHSA-wmwp-pggc-h4mj"},{"ecosystem":"Go","fixed":["3.5.1"],"introduced":["0"],"last_affected":[],"package":"github.com/documize/community","purl":"pkg:golang/github.com/documize/community","source":"GHSA-wmwp-pggc-h4mj"}],"prev":{"headline":"phpMyAdmin unsanitized Git information","id":"CVE-2019-19617"},"products":["n/a"],"published":"2019-12-06","related":[{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2023-23634","kev_date_added":null,"published":"2023-12-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via untrusted Markdown content in Documize, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2019-19619/"}