# CVE-2019-19687: OpenStack Keystone Credential Leakage

> Attackers with project roles can view other users' credentials, including TOTP secrets, when enforce_scope is disabled in OpenStack Keystone.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-19687, GHSA-2j23-fwqm-mgwr, PYSEC-2019-29, RHSA-2019:4358

## What is CVE-2019-19687?

CVE-2019-19687 is a high-severity missing authorization vulnerability in n/a, published on 9 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Keystone 15.0.0 and 16.0.0 is affected by Data Leakage in the list credentials API. Any user with a role on a project is able to list any credentials with the /v3/credentials API when enforce_scope is false. Users with a role on a project are able to view any other users' credentials, which could (for example) leak sign-on information for Time-based One Time Passwords (TOTP). Deployments with enforce_scope set to false are affected. (There will be a slight performance impact for the list credentials API once this issue is fixed.)

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-19687?

5 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 16.0.1 |
| `keystone` | PyPI | From 15.0.0 | 15.0.1 |
| `keystone` | PyPI | From 15.0.0 | 15.0.1 |
| `keystone` | PyPI | From 16.0.0 | 16.0.1 |
| `keystone` | PyPI | From 16.0.0 | 16.0.1 |
| `openstack-keystone` | Red Hat:openstack:15::el8 | All versions | 1:15.0.1-0.20190720060412.5f27c4b.1.el8ost |
| `python3-keystone` | Red Hat:openstack:15::el8 | All versions | 1:15.0.1-0.20190720060412.5f27c4b.1.el8ost |

Products: Openstack Keystone.

## How do I fix CVE-2019-19687?

Upgrade keystone to a fixed version for your release line: 16.0.1 or 15.0.1.

## Is CVE-2019-19687 being exploited?

There is no known exploitation of CVE-2019-19687 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)
- [CVE-2015-7546](https://insights.sbomify.com/CVE-2015-7546/): OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19687 and fix it if it is affected.

What it is: CVE-2019-19687 is a high-severity missing authorization vulnerability in n/a, published on 9 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19687 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 16.0.1
- keystone (PyPI): affected from 15.0.0; fixed in 15.0.1
- keystone (PyPI): affected from 15.0.0; fixed in 15.0.1
- keystone (PyPI): affected from 16.0.0; fixed in 16.0.1
- keystone (PyPI): affected from 16.0.0; fixed in 16.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19687/ (Markdown: https://insights.sbomify.com/CVE-2019-19687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19687
- OSV: https://osv.dev/vulnerability/CVE-2019-19687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19687/
Summaries are generated and may contain mistakes; the official description above is the record.
