# CVE-2019-19702: Modoboa is vulnerable to an XML External Entity Injection (XXE)

> A remote attacker can cause denial of service in Modoboa DMARC reporting by sending malicious XML emails exploiting an XXE vulnerability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vc42-mgr2-w34r, PYSEC-2019-105

## What is CVE-2019-19702?

CVE-2019-19702 is a high-severity vulnerability in n/a, published on 10 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The modoboa-dmarc plugin 1.1.0 for Modoboa is vulnerable to an XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this to perform a denial of service against the DMARC reporting functionality, such as by referencing the /dev/random file within XML documents that are emailed to the address in the rua field of the DMARC records of a domain.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-19702?

3 open source packages ship an affected version, including modoboa-dmarc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modoboa-dmarc` | PyPI | All versions | 1.2.0 |
| `modoboa-dmarc` | PyPI | All versions | 1.2.0 |
| `modoboa-dmarc` | PyPI | All versions | 1.2.0 |

Products: Modoboa Modoboa-Dmarc.

## How do I fix CVE-2019-19702?

Upgrade modoboa-dmarc to 1.2.0 or later.

## Is CVE-2019-19702 being exploited?

There is no known exploitation of CVE-2019-19702 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19702 and fix it if it is affected.

What it is: CVE-2019-19702 is a high-severity vulnerability in n/a, published on 10 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19702 in the wild and no public exploit code.

Affected packages and fixed versions:
- modoboa-dmarc (PyPI): affected all versions; fixed in 1.2.0
- modoboa-dmarc (PyPI): affected all versions; fixed in 1.2.0
- modoboa-dmarc (PyPI): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19702/ (Markdown: https://insights.sbomify.com/CVE-2019-19702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19702
- OSV: https://osv.dev/vulnerability/CVE-2019-19702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19702/
Summaries are generated and may contain mistakes; the official description above is the record.
