CVE-2019-19709 Possible to circumvent title-blacklist
Attackers can bypass Title_blacklist protection in MediaWiki by exploiting redirect mechanisms in the action API, allowing unauthorized page edits.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-19709?
CVE-2019-19709 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.
Weakness: CWE-601
Which versions are affected by CVE-2019-19709?
8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.31.0 | 1.31.6 |
mediawiki/core Packagist | From 1.31.0 | 1.31.6 |
mediawiki/core Packagist | From 1.32.0 | 1.32.6 |
mediawiki/core Packagist | From 1.32.0 | 1.32.6 |
mediawiki/core Packagist | From 1.33.0 | 1.33.2 |
mediawiki/core Packagist | From 1.33.0 | 1.33.2 |
2 more packages
mediawiki/core Packagist | From 1.33.99 | 1.34.0 |
mediawiki/core Packagist | From 1.33.99 | 1.34.0 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2019-19709?
Upgrade mediawiki/core to a fixed version for your release line: 1.31.6, 1.32.6, 1.33.2 or 1.34.0.
Is CVE-2019-19709 being exploited?
There is no known exploitation of CVE-2019-19709 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-19709, DSA-4592-1, GHSA-pjv5-vv93-p648, MGASA-2020-0021, UBUNTU-CVE-2019-19709.