CVE-2019-19712 Information disclosure in the Contao backend

Medium 5.3 Published Updated

Back end users can manipulate URLs to view unauthorized pages and articles in Contao CMS, leading to information disclosure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-19712?

CVE-2019-19712 is a medium-severity missing authorization vulnerability in n/a, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Contao 4.0 through 4.8.5 has Insecure Permissions. Back end users can manipulate the details view URL to show pages and articles that have not been enabled for them.

Weakness: CWE-276

Which versions are affected by CVE-2019-19712?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.

PackageAffectedFixed in
contao/contao PackagistFrom 4.0.04.4.46
contao/contao PackagistFrom 4.0.04.4.46
contao/contao PackagistFrom 4.5.04.8.6
contao/contao PackagistFrom 4.5.04.8.6
contao/core-bundle PackagistFrom 4.0.04.4.46
contao/core-bundle PackagistFrom 4.0.04.4.46
2 more packages
contao/core-bundle PackagistFrom 4.5.04.8.6
contao/core-bundle PackagistFrom 4.5.04.8.6

Products include Contao Contao.

How do I fix CVE-2019-19712?

Upgrade contao/contao to a fixed version for your release line: 4.4.46 or 4.8.6.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2019-19712 being exploited?

There is no known exploitation of CVE-2019-19712 in the wild and no public exploit code.

Sources

Also known as GHSA-4mvc-qc5w-v5qr.

Is CVE-2019-19712 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free