# CVE-2019-19714: Insert tag injection in the Contao login module

> Attackers can inject malicious insert tags into the login module, leading to cross-site scripting and potential account takeover in Contao CMS.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jc43-qrrp-98f5

## What is CVE-2019-19714?

CVE-2019-19714 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contao 4.8.4 and 4.8.5 has Improper Encoding or Escaping of Output. It is possible to inject insert tags into the login module which will be replaced when the page is rendered.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2019-19714?

4 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.8.4 | 4.8.6 |
| `contao/contao` | Packagist | From 4.8.4 | 4.8.6 |
| `contao/core-bundle` | Packagist | From 4.8.4 | 4.8.6 |
| `contao/core-bundle` | Packagist | From 4.8.4 | 4.8.6 |

Products: Contao Contao.

## How do I fix CVE-2019-19714?

Upgrade contao/contao to 4.8.6 or later.

## Is CVE-2019-19714 being exploited?

There is no known exploitation of CVE-2019-19714 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19714 and fix it if it is affected.

What it is: CVE-2019-19714 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19714 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.8.4; fixed in 4.8.6
- contao/contao (Packagist): affected from 4.8.4; fixed in 4.8.6
- contao/core-bundle (Packagist): affected from 4.8.4; fixed in 4.8.6
- contao/core-bundle (Packagist): affected from 4.8.4; fixed in 4.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19714/ (Markdown: https://insights.sbomify.com/CVE-2019-19714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19714
- OSV: https://osv.dev/vulnerability/CVE-2019-19714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19714/
Summaries are generated and may contain mistakes; the official description above is the record.
