{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-19727 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2019-19727 is a medium-severity vulnerability in Opensuse Leap, published on 13 Jan 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-19727 and fix it if it is affected.\n\nWhat it is: CVE-2019-19727 is a medium-severity vulnerability in Opensuse Leap, published on 13 Jan 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-19727 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-19727/ (Markdown: https://insights.sbomify.com/CVE-2019-19727/index.md)","id":"CVE-2019-19727","markdown":"https://insights.sbomify.com/CVE-2019-19727/index.md","name":"CVE-2019-19727","record":{"aliases":["GHSA-wmqm-x8vm-v6mh","SUSE-SU-2020:0228-1","UBUNTU-CVE-2019-19727"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Slurm workload manager","requires_auth":"low_privilege","summary":"Weak permissions on slurmdbd.conf allow attackers to read or modify sensitive configuration data in Slurm.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"slurm","vendor":"schedmd"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"SchedMD Slurm before 18.08.9 and 19.x before 19.05.5 has weak slurmdbd.conf permissions.","ecosystems":["SUSE:Linux Enterprise Module for HPC 15","SUSE:Linux Enterprise Module for HPC 15 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Misconfiguration in n/a","id":"CVE-2019-19727","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap"],"type":"misconfiguration","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2019-19728"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for HPC 15","fixed":["17.11.13-6.23.1"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/suse/slurm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2015","source":"SUSE-SU-2020:0228-1"},{"ecosystem":"SUSE:Linux Enterprise Module for HPC 15 SP1","fixed":["17.11.13-6.23.1"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/suse/slurm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2015%20SP1","source":"SUSE-SU-2020:0228-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2019-19726"},"products":["n/a"],"published":"2020-01-13","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Weak permissions on slurmdbd.conf allow attackers to read or modify sensitive configuration data in Slurm.","url":"https://insights.sbomify.com/CVE-2019-19727/"}