# CVE-2019-19745: Unrestricted file uploads in Contao

> Authenticated back-end users can upload arbitrary files to execute code on the server via local file inclusion in Contao.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wjx8-cgrm-hh8p

## What is CVE-2019-19745?

CVE-2019-19745 is a high-severity vulnerability in n/a, published on 17 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contao 4.0 through 4.8.5 allows PHP local file inclusion. A back end user with access to the form generator can upload arbitrary files and execute them on the server.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-19745?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.46 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.46 |
| `contao/contao` | Packagist | From 4.5.0 | 4.8.6 |
| `contao/contao` | Packagist | From 4.5.0 | 4.8.6 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.46 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.46 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.8.6 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.8.6 |

Products: Contao Contao.

## How do I fix CVE-2019-19745?

Upgrade contao/contao to a fixed version for your release line: 4.4.46 or 4.8.6.

## Is CVE-2019-19745 being exploited?

There is no known exploitation of CVE-2019-19745 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)
- [CVE-2024-45398](https://insights.sbomify.com/CVE-2024-45398/): Remote command execution through file upload in contao/core-bundle (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19745 and fix it if it is affected.

What it is: CVE-2019-19745 is a high-severity vulnerability in n/a, published on 17 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19745 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.46
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.46
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.8.6
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.8.6
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.46
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.46
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.8.6
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19745/ (Markdown: https://insights.sbomify.com/CVE-2019-19745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19745
- OSV: https://osv.dev/vulnerability/CVE-2019-19745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19745/
Summaries are generated and may contain mistakes; the official description above is the record.
