# CVE-2019-19844: Django Potential account hijack via password reset form

> Attackers can take over user accounts by exploiting Unicode case transformations in email addresses during password reset requests.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-19844, DEBIAN-CVE-2019-19844, DLA-2042-1, DSA-4598-1, GHSA-vfq6-hq5r-27r6, PYSEC-2019-16, UBUNTU-CVE-2019-19844, USN-4224-1, USN-6722-1, openSUSE-SU-2024:11224-1, openSUSE-SU-2024:14065-1, openSUSE-SU-2026:11570-1

## What is CVE-2019-19844?

CVE-2019-19844 is a critical authentication bypass vulnerability in Canonical Ubuntu Linux, published on 18 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. A suitably crafted email address (that is equal to an existing user's email address after case transformation of Unicode characters) would allow an attacker to be sent a password reset token for the matched user account. (One mitigation in the new releases is to send password reset tokens only to the registered user email address.)

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2019-19844?

7 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.11.27, 2.2.9 |
| `django` | PyPI | All versions | 1.11.27 |
| `django` | PyPI | From 2.0 | 2.2.9 |
| `django` | PyPI | From 3.0 | 3.0.1 |
| `Django` | PyPI | All versions | 1.11.27 |
| `Django` | PyPI | From 2.0 | 2.2.9 |
| `Django` | PyPI | From 3.0 | 3.0.1 |
| `python-django-allauth` | openSUSE:Tumbleweed | All versions | 0.63.3-1.1 |
| `python-django-allauth` | openSUSE:Tumbleweed | All versions | 65.19.1-1.1 |

Products: Canonical Ubuntu Linux, Djangoproject Django.

## How do I fix CVE-2019-19844?

Upgrade django to a fixed version for your release line: 1.11.27, 2.2.9 or 3.0.1.

## Is CVE-2019-19844 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-19844 exists.

Public exploit code:

- PoC for CVE-2019-19844(https://www.djangoproject.com/weblog/2019/dec/18/security-releases/) (github_poc): https://github.com/ryu22e/django_cve_2019_19844_poc
- PoC for CVE-2019-19844 ( https://www.djangoproject.com/weblog/2019/dec/18/security-releases/ ) (github_poc): https://github.com/andripwn/django_cve201919844
- CVE-2019-19844 Docker Edition (github_poc): https://github.com/0xsha/CVE_2019_19844
- Django < 3.0 < 2.2 < 1.11 - Account Hijack (exploitdb)

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19844 and fix it if it is affected.

What it is: CVE-2019-19844 is a critical authentication bypass vulnerability in Canonical Ubuntu Linux, published on 18 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-19844 exists.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.11.27, 2.2.9
- django (PyPI): affected all versions; fixed in 1.11.27
- django (PyPI): affected from 2.0; fixed in 2.2.9
- django (PyPI): affected from 3.0; fixed in 3.0.1
- Django (PyPI): affected all versions; fixed in 1.11.27
- Django (PyPI): affected from 2.0; fixed in 2.2.9
- Django (PyPI): affected from 3.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19844/ (Markdown: https://insights.sbomify.com/CVE-2019-19844/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19844
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19844
- OSV: https://osv.dev/vulnerability/CVE-2019-19844

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19844/
Summaries are generated and may contain mistakes; the official description above is the record.
