# CVE-2019-19848: TYPO3 Directory Traversal on ZIP extraction

> Administrators can exploit directory traversal in the Extension Manager to read or modify files outside the intended directory.

- **Severity:** Medium 6.8 (`CVSS:3.0/AC:L/AV:N/A:H/C:H/I:H/PR:H/S:U/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-77p4-wfr8-977w

## What is CVE-2019-19848?

CVE-2019-19848 is a medium-severity path traversal vulnerability in Typo3 Typo3, published on 17 Dec 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. It has been discovered that the extraction of manually uploaded ZIP archives in Extension Manager is vulnerable to directory traversal. Admin privileges are required in order to exploit this vulnerability. (In v9 LTS and later, System Maintainer privileges are also required.)

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-19848?

12 open source packages ship an affected version, including typo3/cms and typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 10.0.0 | 10.2.2 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.2.2 |
| `typo3/cms` | Packagist | From 8.0.0 | 8.7.30 |
| `typo3/cms` | Packagist | From 8.0.0 | 8.7.30 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.12 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.12 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.2.2 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.2.2 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.30 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.30 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.12 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.12 |

Products: Typo3 Typo3.

## How do I fix CVE-2019-19848?

Upgrade typo3/cms to a fixed version for your release line: 10.2.2, 8.7.30 or 9.5.12.

## Is CVE-2019-19848 being exploited?

There is no known exploitation of CVE-2019-19848 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19848 and fix it if it is affected.

What it is: CVE-2019-19848 is a medium-severity path traversal vulnerability in Typo3 Typo3, published on 17 Dec 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-19848 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.2.2
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.2.2
- typo3/cms (Packagist): affected from 8.0.0; fixed in 8.7.30
- typo3/cms (Packagist): affected from 8.0.0; fixed in 8.7.30
- typo3/cms (Packagist): affected from 9.0.0; fixed in 9.5.12
- typo3/cms (Packagist): affected from 9.0.0; fixed in 9.5.12
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.2.2
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.2.2
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.30
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.30
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.12
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19848/ (Markdown: https://insights.sbomify.com/CVE-2019-19848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19848
- OSV: https://osv.dev/vulnerability/CVE-2019-19848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19848/
Summaries are generated and may contain mistakes; the official description above is the record.
