CVE-2019-19849 TYPO3 Insecure Deserialization in Query Generator & Query View
Insecure deserialization in TYPO3 allows code execution if specific backend extensions are installed and accessible by authenticated users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-19849?
CVE-2019-19849 is a high-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 17 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. It has been discovered that the classes QueryGenerator and QueryView are vulnerable to insecure deserialization. One exploitable scenario requires having the system extension ext:lowlevel (Backend Module: DB Check) installed, with a valid backend user who has administrator privileges. The other exploitable scenario requires having the system extension ext:sys_action installed, with a valid backend user who has limited privileges.
Weakness: CWE-502
Which versions are affected by CVE-2019-19849?
12 open source packages ship an affected version, including typo3/cms and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.2.1 |
typo3/cms Packagist | From 10.0.0 | 10.2.1 |
typo3/cms Packagist | From 8.0.0 | 8.7.30 |
typo3/cms Packagist | From 8.0.0 | 8.7.30 |
typo3/cms Packagist | From 9.0.0 | 9.5.12 |
typo3/cms Packagist | From 9.0.0 | 9.5.12 |
6 more packages
typo3/cms-core Packagist | From 10.0.0 | 10.2.1 |
typo3/cms-core Packagist | From 10.0.0 | 10.2.1 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.30 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.30 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.12 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.12 |
Products include Typo3 Typo3.
How do I fix CVE-2019-19849?
Upgrade typo3/cms to a fixed version for your release line: 10.2.1, 8.7.30 or 9.5.12.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-19849 being exploited?
There is no known exploitation of CVE-2019-19849 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-rcgc-4xfc-564v.