CVE-2019-19850 TYPO3 SQL Injection in low-level Query Generator
SQL injection in TYPO3 QueryGenerator allows data access or modification, requiring admin privileges and the lowlevel extension.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-19850?
CVE-2019-19850 is a medium-severity SQL injection vulnerability in Typo3 Typo3, published on 17 Dec 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. Because escaping of user-submitted content is mishandled, the class QueryGenerator is vulnerable to SQL injection. Exploitation requires having the system extension ext:lowlevel installed, and a valid backend user who has administrator privileges.
Weakness: CWE-89
Which versions are affected by CVE-2019-19850?
12 open source packages ship an affected version, including typo3/cms and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0 | 10.2.2 |
typo3/cms Packagist | From 10.0 | 10.2.2 |
typo3/cms Packagist | From 8.0 | 8.7.30 |
typo3/cms Packagist | From 8.0 | 8.7.30 |
typo3/cms Packagist | From 9.0 | 9.5.12 |
typo3/cms Packagist | From 9.0 | 9.5.12 |
6 more packages
typo3/cms-core Packagist | From 10.0 | 10.2.2 |
typo3/cms-core Packagist | From 10.0 | 10.2.2 |
typo3/cms-core Packagist | From 8.0 | 8.7.30 |
typo3/cms-core Packagist | From 8.0 | 8.7.30 |
typo3/cms-core Packagist | From 9.0 | 9.5.12 |
typo3/cms-core Packagist | From 9.0 | 9.5.12 |
Products include Typo3 Typo3.
How do I fix CVE-2019-19850?
Upgrade typo3/cms to a fixed version for your release line: 10.2.2, 8.7.30 or 9.5.12.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2019-19850 being exploited?
There is no known exploitation of CVE-2019-19850 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-59pj-7mjh-4465.