# CVE-2019-19879: Business logic in n/a

> Attackers can bypass security policies due to incorrect parsing of negation expressions in the Sentinel policy engine.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-q2vj-q3hr-h9m7

## What is CVE-2019-19879?

CVE-2019-19879 is a high-severity vulnerability in n/a, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Sentinel up to 0.10.1 incorrectly parsed negation in certain policy expressions. Fixed in 0.10.2.

## Which versions are affected by CVE-2019-19879?

It affects 1 product.


Products: Hashicorp Sentinel.

## How do I fix CVE-2019-19879?

No fix has been published for CVE-2019-19879 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-19879 being exploited?

There is no known exploitation of CVE-2019-19879 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-44139](https://insights.sbomify.com/CVE-2021-44139/): Server-side request forgery in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19879 and fix it if it is affected.

What it is: CVE-2019-19879 is a high-severity vulnerability in n/a, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19879 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19879/ (Markdown: https://insights.sbomify.com/CVE-2019-19879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19879
- OSV: https://osv.dev/vulnerability/CVE-2019-19879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19879/
Summaries are generated and may contain mistakes; the official description above is the record.
