# CVE-2019-19899: Pebble Templates Improper Input Validation vulnerability

> Attackers can bypass Class access restrictions in Pebble Templates by exploiting the forName method, potentially leading to further exploitation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-83m8-7hj8-ff5w

## What is CVE-2019-19899?

CVE-2019-19899 is a critical vulnerability in n/a, published on 18 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pebble Templates 3.1.2 allows attackers to bypass a protection mechanism (intended to block access to instances of java.lang.Class) because getClass is accessible via the public static java.lang.Class java.lang.Class.forName(java.lang.Module,java.lang.String) signature.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-19899?

2 open source packages ship an affected version, including io.pebbletemplates:pebble-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.pebbletemplates:pebble-project` | Maven | All versions | 3.1.4 |
| `io.pebbletemplates:pebble-project` | Maven | All versions | 3.1.4 |

Products: Pebbletemplates Pebble Templates.

## How do I fix CVE-2019-19899?

Upgrade io.pebbletemplates:pebble-project to 3.1.4 or later.

## Is CVE-2019-19899 being exploited?

There is no known exploitation of CVE-2019-19899 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-37767](https://insights.sbomify.com/CVE-2022-37767/): Pebble Templates protection mechanism bypass can lead to arbitrary code execution (critical 9.8)
- [CVE-2025-1686](https://insights.sbomify.com/CVE-2025-1686/): Pebble has Arbitrary Local File Inclusion (LFI) Vulnerability via `include` macro (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19899 and fix it if it is affected.

What it is: CVE-2019-19899 is a critical vulnerability in n/a, published on 18 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19899 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.pebbletemplates:pebble-project (Maven): affected all versions; fixed in 3.1.4
- io.pebbletemplates:pebble-project (Maven): affected all versions; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19899/ (Markdown: https://insights.sbomify.com/CVE-2019-19899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19899
- OSV: https://osv.dev/vulnerability/CVE-2019-19899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19899/
Summaries are generated and may contain mistakes; the official description above is the record.
