{"answers":{"affected":"3 open source packages ship an affected version, including pillow. It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-19911 in the wild and no public exploit code.","fix":"Upgrade pillow to 6.2.2 or later.","what":"CVE-2019-19911 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 5 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-19911 and fix it if it is affected.\n\nWhat it is: CVE-2019-19911 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 5 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-19911 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pillow (PyPI): affected all versions; fixed in 6.2.2\n- pillow (PyPI): affected all versions; fixed in 6.2.2\n- pillow (PyPI): affected all versions; fixed in 6.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-19911/ (Markdown: https://insights.sbomify.com/CVE-2019-19911/index.md)","id":"CVE-2019-19911","markdown":"https://insights.sbomify.com/CVE-2019-19911/index.md","name":"CVE-2019-19911","record":{"aliases":["ALPINE-CVE-2019-19911","DEBIAN-CVE-2019-19911","GHSA-5gm3-px64-rw72","PYSEC-2020-172","UBUNTU-CVE-2019-19911"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python imaging library","requires_auth":"none","summary":"An attacker can cause a denial of service in Pillow by triggering an integer overflow via a crafted image with a large number of bands.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"pillow","vendor":"python"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"There is a DoS vulnerability in Pillow before 6.2.2 caused by FpxImagePlugin.py calling the range function on an unvalidated 32-bit integer if the number of bands is large. On Windows running 32-bit Python, this results in an OverflowError or MemoryError due to the 2 GB limit. However, on Linux running 64-bit Python this results in the process being terminated by the OOM killer.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uncontrolled Resource Consumption in Pillow","id":"CVE-2019-19911","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","fedoraproject:fedora","python:pillow"],"type":"integer_overflow","year":"2019"},"n_packages":3,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-19912"},"packages":[{"ecosystem":"PyPI","fixed":["6.2.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":null,"source":"GHSA-5gm3-px64-rw72"},{"ecosystem":"PyPI","fixed":["6.2.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"GHSA-5gm3-px64-rw72"},{"ecosystem":"PyPI","fixed":["6.2.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"PYSEC-2020-172"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-19910"},"products":["n/a"],"published":"2020-01-05","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in Pillow by triggering an integer overflow via a crafted image with a large number of bands.","url":"https://insights.sbomify.com/CVE-2019-19911/"}