# CVE-2019-19919: Prototype Pollution in handlebars

> Attackers can execute arbitrary code via prototype pollution in Handlebars templates, affecting applications using the library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-19919, GHSA-w457-6q6x-cgp9, MINI-7qwq-2gxf-8262, MINI-8h6q-4jm9-qf24, ROOT-APP-NPM-CVE-2019-19919, UBUNTU-CVE-2019-19919

## What is CVE-2019-19919?

CVE-2019-19919 is a critical code injection vulnerability in n/a, published on 20 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Object's __proto__ and __defineGetter__ properties, which may allow an attacker to execute arbitrary code through crafted payloads.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2019-19919?

6 open source packages ship an affected version, including handlebars and bootstrap-wysihtml5-rails. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handlebars` | npm | All versions | 3.0.8 |
| `handlebars` | npm | All versions | 3.0.8 |
| `handlebars` | npm | From 4.0.0 | 4.3.0 |
| `handlebars` | npm | From 4.0.0 | 4.3.0 |
| `bootstrap-wysihtml5-rails` | RubyGems | From 0.3.3.5 to 0.3.3.8 | None |
| `bootstrap-wysihtml5-rails` | RubyGems | From 0.3.3.5 to 0.3.3.8 | None |

Products: Handlebars.js Project Handlebars.js, Tenable Tenable.sc.

## How do I fix CVE-2019-19919?

Upgrade handlebars to a fixed version for your release line: 3.0.8 or 4.3.0.

## Is CVE-2019-19919 being exploited?

There is no known exploitation of CVE-2019-19919 in the wild and no public exploit code.

Public exploit code:

- Handlebars Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') Vulnerability (github_poc): https://github.com/fazilbaig1/CVE-2019-19919

## Other vulnerabilities in n/a

- [CVE-2015-8861](https://insights.sbomify.com/CVE-2015-8861/): Cross-Site Scripting in handlebars (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19919 and fix it if it is affected.

What it is: CVE-2019-19919 is a critical code injection vulnerability in n/a, published on 20 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19919 in the wild and no public exploit code.

Affected packages and fixed versions:
- handlebars (npm): affected all versions; fixed in 3.0.8
- handlebars (npm): affected all versions; fixed in 3.0.8
- handlebars (npm): affected from 4.0.0; fixed in 4.3.0
- handlebars (npm): affected from 4.0.0; fixed in 4.3.0
- bootstrap-wysihtml5-rails (RubyGems): affected from 0.3.3.5 up to 0.3.3.8; no fix listed
- bootstrap-wysihtml5-rails (RubyGems): affected from 0.3.3.5 up to 0.3.3.8; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19919/ (Markdown: https://insights.sbomify.com/CVE-2019-19919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19919
- OSV: https://osv.dev/vulnerability/CVE-2019-19919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19919/
Summaries are generated and may contain mistakes; the official description above is the record.
