# CVE-2019-19921: opencontainers runc contains procfs race condition with a shared volume mount

> An attacker with container spawn privileges can escalate privileges via custom volume mounts in runc, bypassing isolation controls.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2025-NR50910, CLEANSTART-2026-UZ87660, DEBIAN-CVE-2019-19921, GHSA-fh74-hm69-rqjw, GO-2021-0087, MGASA-2020-0103, RHSA-2020:0688, RHSA-2020:0695, RHSA-2020:0942, RHSA-2020:1485, SUSE-SU-2020:0375-1, SUSE-SU-2020:0376-1, SUSE-SU-2020:0944-1, UBUNTU-CVE-2019-19921, openSUSE-SU-2020:0219-1

## What is CVE-2019-19921?

CVE-2019-19921 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 12 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

runc through 1.0.0-rc9 has Incorrect Access Control leading to Escalation of Privileges, related to libcontainer/rootfs_linux.go. To exploit this, an attacker must be able to spawn two containers with custom volume-mount configurations, and be able to run custom images. (This vulnerability does not affect Docker due to an implementation detail that happens to block the attack.)

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2019-19921?

3 open source packages ship an affected version, including github.com/opencontainers/runc. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/opencontainers/runc` | Go | All versions | 1.0.0-rc9.0.20200122160610-2fc03cc11c77 |
| `github.com/opencontainers/runc` | Go | All versions | 1.0.0-rc9.0.20200122160610-2fc03cc11c77 |
| `github.com/opencontainers/runc` | Go | All versions | 1.0.0-rc9.0.20200122160610-2fc03cc11c77 |
| `runc` | Red Hat:openshift:4.1::el8 | All versions | 0:1.0.0-63.rc8.rhaos4.1.git3cbe540.el8_0 |
| `runc-debuginfo` | Red Hat:openshift:4.1::el8 | All versions | 0:1.0.0-63.rc8.rhaos4.1.git3cbe540.el8_0 |
| `runc-debugsource` | Red Hat:openshift:4.1::el8 | All versions | 0:1.0.0-63.rc8.rhaos4.1.git3cbe540.el8_0 |
| `runc` | Red Hat:openshift:4.2::el8 | All versions | 0:1.0.0-63.rc10.rhaos4.2.gitdc9208a.el8 |
| `runc-debuginfo` | Red Hat:openshift:4.2::el8 | All versions | 0:1.0.0-63.rc10.rhaos4.2.gitdc9208a.el8 |
| `runc-debugsource` | Red Hat:openshift:4.2::el8 | All versions | 0:1.0.0-63.rc10.rhaos4.2.gitdc9208a.el8 |
| `runc` | Red Hat:openshift:4.3::el7 | All versions | 0:1.0.0-66.rc10.rhaos4.3.el7_8 |
| `runc-debuginfo` | Red Hat:openshift:4.3::el7 | All versions | 0:1.0.0-66.rc10.rhaos4.3.el7_8 |
| `runc` | Red Hat:rhel_extras_other:7 | All versions | 0:1.0.0-66.rc8.el7_7 |
| `runc-debuginfo` | Red Hat:rhel_extras_other:7 | All versions | 0:1.0.0-66.rc8.el7_7 |
| `docker-runc` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.0.0rc8+gitr3917_3e425f80a8c9-1.40.1 |
| `docker-runc` | SUSE:Linux Enterprise Module for Containers 15 SP1 | All versions | 1.0.0rc8+gitr3917_3e425f80a8c9-6.32.1 |
| `runc` | SUSE:Linux Enterprise Module for Containers 15 SP1 | All versions | 1.0.0~rc10-1.9.1 |
| `docker-runc` | openSUSE:Leap 15.1 | All versions | 1.0.0rc8+gitr3917_3e425f80a8c9-lp151.3.15.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Linuxfoundation Runc, Opensuse Leap, Redhat Openshift Container Platform.

## How do I fix CVE-2019-19921?

Upgrade github.com/opencontainers/runc to 1.0.0-rc9.0.20200122160610-2fc03cc11c77 or later.

## Is CVE-2019-19921 being exploited?

There is no known exploitation of CVE-2019-19921 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19921 and fix it if it is affected.

What it is: CVE-2019-19921 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 12 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-19921 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.0.0-rc9.0.20200122160610-2fc03cc11c77
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.0.0-rc9.0.20200122160610-2fc03cc11c77
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.0.0-rc9.0.20200122160610-2fc03cc11c77

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19921/ (Markdown: https://insights.sbomify.com/CVE-2019-19921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19921
- OSV: https://osv.dev/vulnerability/CVE-2019-19921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19921/
Summaries are generated and may contain mistakes; the official description above is the record.
