# CVE-2019-19935: DOM-based cross-site scripting in Froala Editor


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jul 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h236-g5gh-vq6c

## What is CVE-2019-19935?

CVE-2019-19935 is a medium-severity vulnerability in n/a, published on 7 Jul 2020. 

### Official description

Froala Editor before 3.2.3 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-19935?

2 open source packages ship an affected version, including froala-editor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froala-editor` | npm | All versions | 3.2.3 |
| `froala-editor` | npm | All versions | 3.2.3 |

Products: Froala Froala Editor.

## How do I fix CVE-2019-19935?

Upgrade froala-editor to 3.2.3 or later.

## Is CVE-2019-19935 being exploited?

There is no known exploitation of CVE-2019-19935 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-43263](https://insights.sbomify.com/CVE-2023-43263/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-42426](https://insights.sbomify.com/CVE-2023-42426/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2020-22864](https://insights.sbomify.com/CVE-2020-22864/): Cross site scripting in froala-editor (medium 6.1)
- [CVE-2021-30109](https://insights.sbomify.com/CVE-2021-30109/): Cross-site Scripting in Froala Editor (medium 6.1)
- [CVE-2020-26523](https://insights.sbomify.com/CVE-2020-26523/): Froala WYSIWYG Editor XSS Vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-19935 and fix it if it is affected.

What it is: CVE-2019-19935 is a medium-severity vulnerability in n/a, published on 7 Jul 2020. 
Exploitation: There is no known exploitation of CVE-2019-19935 in the wild and no public exploit code.

Affected packages and fixed versions:
- froala-editor (npm): affected all versions; fixed in 3.2.3
- froala-editor (npm): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-19935/ (Markdown: https://insights.sbomify.com/CVE-2019-19935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-19935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-19935
- OSV: https://osv.dev/vulnerability/CVE-2019-19935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-19935/
Summaries are generated and may contain mistakes; the official description above is the record.
