# CVE-2019-20008: Cross-site scripting in n/a

> Attackers can inject stored XSS payloads via project names, potentially executing scripts on the vulnerability-scan scheduling page.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h3q5-2vhj-42r9, PYSEC-2019-112

## What is CVE-2019-20008?

CVE-2019-20008 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Archery before 1.3, inserting an XSS payload into a project name (either by creating a new project or editing an existing one) will result in stored XSS on the vulnerability-scan scheduling page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-20008?

1 open source package ship an affected version, including pyarchery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyarchery` | PyPI | All versions | 1.3.0 |

Products: Archerysec Archery.

## How do I fix CVE-2019-20008?

Upgrade pyarchery to 1.3.0 or later.

## Is CVE-2019-20008 being exploited?

There is no known exploitation of CVE-2019-20008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20008 and fix it if it is affected.

What it is: CVE-2019-20008 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-20008 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyarchery (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20008/ (Markdown: https://insights.sbomify.com/CVE-2019-20008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20008
- OSV: https://osv.dev/vulnerability/CVE-2019-20008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20008/
Summaries are generated and may contain mistakes; the official description above is the record.
