# CVE-2019-20149: Validation Bypass in kind-of

> Attackers can manipulate type detection results in kind-of by overwriting internal attributes, potentially bypassing security checks relying on this library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** AZL-44298, AZL-47271, DEBIAN-CVE-2019-20149, GHSA-6c8f-qphg-qjgp, UBUNTU-CVE-2019-20149

## What is CVE-2019-20149?

CVE-2019-20149 is a high-severity vulnerability in n/a, published on 30 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ctorName in index.js in kind-of v6.0.2 allows external user input to overwrite certain internal attributes via a conflicting name, as demonstrated by 'constructor': {'name':'Symbol'}. Hence, a crafted payload can overwrite this builtin attribute to manipulate the type detection result.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2019-20149?

2 open source packages ship an affected version, including kind-of. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kind-of` | npm | From 6.0.0 | 6.0.3 |
| `kind-of` | npm | From 6.0.0 | 6.0.3 |

Products: Kind-of Project Kind-Of.

## How do I fix CVE-2019-20149?

Upgrade kind-of to 6.0.3 or later.

## Is CVE-2019-20149 being exploited?

There is no known exploitation of CVE-2019-20149 in the wild and no public exploit code.

Public exploit code:

- https://github.com/mrknowledgshare/testing_cve-2019-20149 (github_poc): https://github.com/mrknowledgshare/testing_cve-2019-20149

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20149 and fix it if it is affected.

What it is: CVE-2019-20149 is a high-severity vulnerability in n/a, published on 30 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-20149 in the wild and no public exploit code.

Affected packages and fixed versions:
- kind-of (npm): affected from 6.0.0; fixed in 6.0.3
- kind-of (npm): affected from 6.0.0; fixed in 6.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20149/ (Markdown: https://insights.sbomify.com/CVE-2019-20149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20149
- OSV: https://osv.dev/vulnerability/CVE-2019-20149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20149/
Summaries are generated and may contain mistakes; the official description above is the record.
