CVE-2019-20330 Deserialization of Untrusted Data in jackson-databind
Attackers can execute arbitrary code via unsafe deserialization in jackson-databind due to missing blocking for ehcache classes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-20330?
CVE-2019-20330 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 3 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
FasterXML jackson-databind 2.x before 2.9.10.2 lacks certain net.sf.ehcache blocking.
Weakness: CWE-502
Which versions are affected by CVE-2019-20330?
8 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 30 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | From 2.0.0 | 2.6.7.4 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.0.0 | 2.6.7.4 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.7.9.7 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.7.9.7 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.5 |
2 more packages
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10.2 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10.2 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Active Iq Unified Manager, Netapp Oncommand Api Services, Netapp Service Level Manager, Netapp Snapcenter and 24 more.
How do I fix CVE-2019-20330?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.4, 2.7.9.7, 2.8.11.5 or 2.9.10.2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-20330 being exploited?
There is no known exploitation of CVE-2019-20330 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-MC90511, DEBIAN-CVE-2019-20330, GHSA-gww7-p5w4-wrfv, ROOT-APP-MAVEN-CVE-2019-20330, UBUNTU-CVE-2019-20330.