# CVE-2019-20399: Observable Discrepancy in libsecp256k1-rs

> A timing side-channel in the Parity libsecp256k1-rs library allows attackers to leak sensitive information via overflow checks.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7cqg-8449-rmfv, RUSTSEC-2020-0156

## What is CVE-2019-20399?

CVE-2019-20399 is a medium-severity vulnerability in n/a, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A timing vulnerability in the Scalar::check_overflow function in Parity libsecp256k1-rs before 0.3.1 potentially allows an attacker to leak information via a side-channel attack.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2019-20399?

3 open source packages ship an affected version, including libsecp256k1-rs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libsecp256k1-rs` | crates.io | All versions | 0.3.1 |
| `libsecp256k1-rs` | crates.io | All versions | 0.3.1 |
| `libsecp256k1-rs` | crates.io | From 0.0.0-0 | 0.3.1 |

Products: Parity Libsecp256k1.

## How do I fix CVE-2019-20399?

Upgrade libsecp256k1-rs to 0.3.1 or later.

## Is CVE-2019-20399 being exploited?

There is no known exploitation of CVE-2019-20399 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-38195](https://insights.sbomify.com/CVE-2021-38195/): Overflow in libsecp256k1 (critical 9.8)
- [CVE-2019-25003](https://insights.sbomify.com/CVE-2019-25003/): libsecp256k1 contains side-channel timing attack (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20399 and fix it if it is affected.

What it is: CVE-2019-20399 is a medium-severity vulnerability in n/a, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-20399 in the wild and no public exploit code.

Affected packages and fixed versions:
- libsecp256k1-rs (crates.io): affected all versions; fixed in 0.3.1
- libsecp256k1-rs (crates.io): affected all versions; fixed in 0.3.1
- libsecp256k1-rs (crates.io): affected from 0.0.0-0; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20399/ (Markdown: https://insights.sbomify.com/CVE-2019-20399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20399
- OSV: https://osv.dev/vulnerability/CVE-2019-20399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20399/
Summaries are generated and may contain mistakes; the official description above is the record.
