{"answers":{"affected":"6 open source packages ship an affected version, including io.netty:netty, io.netty:netty-handler and org.jboss.netty:netty. It affects 7 products.","exploited":"There is no known exploitation of CVE-2019-20445 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-20445 is a critical vulnerability in Canonical Ubuntu Linux, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-20445 and fix it if it is affected.\n\nWhat it is: CVE-2019-20445 is a critical vulnerability in Canonical Ubuntu Linux, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-20445 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.netty:netty (Maven): affected all versions; no fix listed\n- io.netty:netty (Maven): affected all versions; no fix listed\n- io.netty:netty-handler (Maven): affected from 4.0.0; fixed in 4.1.45\n- io.netty:netty-handler (Maven): affected from 4.0.0; fixed in 4.1.45\n- org.jboss.netty:netty (Maven): affected all versions; no fix listed\n- org.jboss.netty:netty (Maven): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-20445/ (Markdown: https://insights.sbomify.com/CVE-2019-20445/index.md)","id":"CVE-2019-20445","markdown":"https://insights.sbomify.com/CVE-2019-20445/index.md","name":"CVE-2019-20445","record":{"aliases":["CLEANSTART-2026-JQ50151","CLSA-2026-1778028245","DEBIAN-CVE-2019-20445","GHSA-p2v9-g2qv-p635","MINI-cpx5-5gq5-8p59","MINI-j3xm-6pfh-4q28","UBUNTU-CVE-2019-20445"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Netty HTTP decoder","requires_auth":"none","summary":"Netty allows HTTP request smuggling via duplicate Content-Length or Transfer-Encoding headers, enabling request desynchronization attacks.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"spark","vendor":"apache"},{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"netty","vendor":"netty"},{"product":"jboss_amq_clients","vendor":"redhat"},{"product":"jboss_enterprise_application_platform","vendor":"redhat"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be accompanied by a second Content-Length header, or by a Transfer-Encoding header.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Request Smuggling in Netty","id":"CVE-2019-20445","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","fedoraproject:fedora","netty:netty","redhat:jboss_enterprise_application_platform"],"type":"other","year":"2019"},"n_packages":6,"n_references":54,"next":{"headline":"Denial of service in n/a","id":"CVE-2019-20446"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"io.netty:netty","purl":null,"source":"GHSA-p2v9-g2qv-p635"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"io.netty:netty","purl":"pkg:maven/io.netty/netty","source":"GHSA-p2v9-g2qv-p635"},{"ecosystem":"Maven","fixed":["4.1.45"],"introduced":["4.0.0"],"last_affected":[],"package":"io.netty:netty-handler","purl":null,"source":"GHSA-p2v9-g2qv-p635"},{"ecosystem":"Maven","fixed":["4.1.45"],"introduced":["4.0.0"],"last_affected":[],"package":"io.netty:netty-handler","purl":"pkg:maven/io.netty/netty-handler","source":"GHSA-p2v9-g2qv-p635"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"org.jboss.netty:netty","purl":null,"source":"GHSA-p2v9-g2qv-p635"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"org.jboss.netty:netty","purl":"pkg:maven/org.jboss.netty/netty","source":"GHSA-p2v9-g2qv-p635"}],"prev":{"headline":"HTTP Request Smuggling in Netty","id":"CVE-2019-20444"},"products":["n/a"],"published":"2020-01-29","related":[{"cvss_score":8.8,"headline":"Apache Spark Command Injection","id":"CVE-2022-33891","kev_date_added":"2023-03-07","published":"2022-07-18"},{"cvss_score":9.8,"headline":"Improper Authentication in Apache Spark","id":"CVE-2020-9480","kev_date_added":null,"published":"2020-06-23"},{"cvss_score":9.8,"headline":"Remote Code Execution in spark-core","id":"CVE-2018-17190","kev_date_added":null,"published":"2018-11-19"},{"cvss_score":8.8,"headline":"Apache Spark: Spark History Server Code Execution Vulnerability","id":"CVE-2025-54920","kev_date_added":null,"published":"2026-03-14"},{"cvss_score":8.8,"headline":"Apache Spark: Shell command injection via Spark UI","id":"CVE-2023-32007","kev_date_added":null,"published":"2023-05-02"},{"cvss_score":7.8,"headline":"Apache Spark Deserialization of Untrusted Data vulnerability","id":"CVE-2017-12612","kev_date_added":null,"published":"2017-09-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["n/a"]},"summary":"Netty allows HTTP request smuggling via duplicate Content-Length or Transfer-Encoding headers, enabling request desynchronization attacks.","url":"https://insights.sbomify.com/CVE-2019-20445/"}