# CVE-2019-20445: HTTP Request Smuggling in Netty

> Netty allows HTTP request smuggling via duplicate Content-Length or Transfer-Encoding headers, enabling request desynchronization attacks.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2020
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-JQ50151, CLSA-2026-1778028245, DEBIAN-CVE-2019-20445, GHSA-p2v9-g2qv-p635, MINI-cpx5-5gq5-8p59, MINI-j3xm-6pfh-4q28, UBUNTU-CVE-2019-20445

## What is CVE-2019-20445?

CVE-2019-20445 is a critical vulnerability in Canonical Ubuntu Linux, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be accompanied by a second Content-Length header, or by a Transfer-Encoding header.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2019-20445?

6 open source packages ship an affected version, including io.netty:netty, io.netty:netty-handler and org.jboss.netty:netty. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty-handler` | Maven | From 4.0.0 | 4.1.45 |
| `io.netty:netty-handler` | Maven | From 4.0.0 | 4.1.45 |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `org.jboss.netty:netty` | Maven | All versions | None |

Products: Apache Spark, Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Netty Netty, Redhat Jboss Amq Clients, Redhat Jboss Enterprise Application Platform.

## How do I fix CVE-2019-20445?

Upgrade to a fixed version.

## Is CVE-2019-20445 being exploited?

There is no known exploitation of CVE-2019-20445 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)
- [CVE-2023-32007](https://insights.sbomify.com/CVE-2023-32007/): Apache Spark: Shell command injection via Spark UI (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20445 and fix it if it is affected.

What it is: CVE-2019-20445 is a critical vulnerability in Canonical Ubuntu Linux, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-20445 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty-handler (Maven): affected from 4.0.0; fixed in 4.1.45
- io.netty:netty-handler (Maven): affected from 4.0.0; fixed in 4.1.45
- org.jboss.netty:netty (Maven): affected all versions; no fix listed
- org.jboss.netty:netty (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20445/ (Markdown: https://insights.sbomify.com/CVE-2019-20445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20445
- OSV: https://osv.dev/vulnerability/CVE-2019-20445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20445/
Summaries are generated and may contain mistakes; the official description above is the record.
