{"answers":{"affected":"2 open source packages ship an affected version, including globalpayments/php-sdk. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-20455 in the wild and no public exploit code.","fix":"Upgrade globalpayments/php-sdk to 2.0.0 or later.","what":"CVE-2019-20455 is a medium-severity vulnerability in n/a, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-20455 and fix it if it is affected.\n\nWhat it is: CVE-2019-20455 is a medium-severity vulnerability in n/a, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-20455 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- globalpayments/php-sdk (Packagist): affected all versions; fixed in 2.0.0\n- globalpayments/php-sdk (Packagist): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-20455/ (Markdown: https://insights.sbomify.com/CVE-2019-20455/index.md)","id":"CVE-2019-20455","markdown":"https://insights.sbomify.com/CVE-2019-20455/index.md","name":"CVE-2019-20455","record":{"aliases":["GHSA-pm77-c4q7-3fwj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP payment SDK","requires_auth":"none","summary":"The PHP payment SDK fails to validate SSL certificates, allowing attackers to intercept sensitive payment data via man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"php_sdk","vendor":"globalpayments"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Gateways/Gateway.php in Heartland \u0026 Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in Heartland \u0026 Global Payments PHP SDK","id":"CVE-2019-20455","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Command injection in n/a","id":"CVE-2019-20456"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"globalpayments/php-sdk","purl":null,"source":"GHSA-pm77-c4q7-3fwj"},{"ecosystem":"Packagist","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"globalpayments/php-sdk","purl":"pkg:composer/globalpayments/php-sdk","source":"GHSA-pm77-c4q7-3fwj"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2019-20454"},"products":["n/a"],"published":"2020-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"The PHP payment SDK fails to validate SSL certificates, allowing attackers to intercept sensitive payment data via man-in-the-middle attacks.","url":"https://insights.sbomify.com/CVE-2019-20455/"}