# CVE-2019-20455: Improper Certificate Validation in Heartland & Global Payments PHP SDK

> The PHP payment SDK fails to validate SSL certificates, allowing attackers to intercept sensitive payment data via man-in-the-middle attacks.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pm77-c4q7-3fwj

## What is CVE-2019-20455?

CVE-2019-20455 is a medium-severity vulnerability in n/a, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-20455?

2 open source packages ship an affected version, including globalpayments/php-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `globalpayments/php-sdk` | Packagist | All versions | 2.0.0 |
| `globalpayments/php-sdk` | Packagist | All versions | 2.0.0 |

Products: Globalpayments Php Sdk.

## How do I fix CVE-2019-20455?

Upgrade globalpayments/php-sdk to 2.0.0 or later.

## Is CVE-2019-20455 being exploited?

There is no known exploitation of CVE-2019-20455 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20455 and fix it if it is affected.

What it is: CVE-2019-20455 is a medium-severity vulnerability in n/a, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-20455 in the wild and no public exploit code.

Affected packages and fixed versions:
- globalpayments/php-sdk (Packagist): affected all versions; fixed in 2.0.0
- globalpayments/php-sdk (Packagist): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20455/ (Markdown: https://insights.sbomify.com/CVE-2019-20455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20455
- OSV: https://osv.dev/vulnerability/CVE-2019-20455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20455/
Summaries are generated and may contain mistakes; the official description above is the record.
