{"answers":{"affected":"3 open source packages ship an affected version, including pyyaml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-20477 in the wild and no public exploit code.","fix":"Upgrade pyyaml to a fixed version for your release line: 5.2 or 5.2b1.","what":"CVE-2019-20477 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-20477 and fix it if it is affected.\n\nWhat it is: CVE-2019-20477 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-20477 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyyaml (PyPI): affected from 5.1; fixed in 5.2\n- pyyaml (PyPI): affected from 5.1; fixed in 5.2\n- pyyaml (PyPI): affected from 5.1; fixed in 5.2b1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-20477/ (Markdown: https://insights.sbomify.com/CVE-2019-20477/index.md)","id":"CVE-2019-20477","markdown":"https://insights.sbomify.com/CVE-2019-20477/index.md","name":"CVE-2019-20477","record":{"aliases":["DEBIAN-CVE-2019-20477","GHSA-3pqx-4fqf-j49f","PYSEC-2020-176"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python YAML library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe deserialization in PyYAML's load functions, affecting applications using this library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pyyaml","vendor":"pyyaml"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data in PyYAML","id":"CVE-2019-20477","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"deserialization","year":"2019"},"n_packages":3,"n_references":4,"next":{"headline":"Deserialization in n/a","id":"CVE-2019-20478"},"packages":[{"ecosystem":"PyPI","fixed":["5.2"],"introduced":["5.1"],"last_affected":[],"package":"pyyaml","purl":null,"source":"GHSA-3pqx-4fqf-j49f"},{"ecosystem":"PyPI","fixed":["5.2"],"introduced":["5.1"],"last_affected":[],"package":"pyyaml","purl":"pkg:pypi/pyyaml","source":"GHSA-3pqx-4fqf-j49f"},{"ecosystem":"PyPI","fixed":["5.2b1"],"introduced":["5.1"],"last_affected":[],"package":"pyyaml","purl":"pkg:pypi/pyyaml","source":"PYSEC-2020-176"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2019-20474"},"products":["n/a"],"published":"2020-02-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via unsafe deserialization in PyYAML's load functions, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2019-20477/"}