# CVE-2019-20477: Deserialization of Untrusted Data in PyYAML

> Attackers can execute arbitrary code via unsafe deserialization in PyYAML's load functions, affecting applications using this library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-20477, GHSA-3pqx-4fqf-j49f, PYSEC-2020-176

## What is CVE-2019-20477?

CVE-2019-20477 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-20477?

3 open source packages ship an affected version, including pyyaml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyyaml` | PyPI | From 5.1 | 5.2 |
| `pyyaml` | PyPI | From 5.1 | 5.2 |
| `pyyaml` | PyPI | From 5.1 | 5.2b1 |

Products: Fedoraproject Fedora, Pyyaml Pyyaml.

## How do I fix CVE-2019-20477?

Upgrade pyyaml to a fixed version for your release line: 5.2 or 5.2b1.

## Is CVE-2019-20477 being exploited?

There is no known exploitation of CVE-2019-20477 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20477 and fix it if it is affected.

What it is: CVE-2019-20477 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-20477 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyyaml (PyPI): affected from 5.1; fixed in 5.2
- pyyaml (PyPI): affected from 5.1; fixed in 5.2
- pyyaml (PyPI): affected from 5.1; fixed in 5.2b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20477/ (Markdown: https://insights.sbomify.com/CVE-2019-20477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20477
- OSV: https://osv.dev/vulnerability/CVE-2019-20477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20477/
Summaries are generated and may contain mistakes; the official description above is the record.
