{"answers":{"affected":"2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-20891 in the wild and no public exploit code.","fix":"Upgrade woocommerce/woocommerce to 3.6.5 or later.","what":"CVE-2019-20891 is a high-severity cross-site scripting vulnerability in n/a, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-20891 and fix it if it is affected.\n\nWhat it is: CVE-2019-20891 is a high-severity cross-site scripting vulnerability in n/a, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-20891 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 3.6.5\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 3.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-20891/ (Markdown: https://insights.sbomify.com/CVE-2019-20891/index.md)","id":"CVE-2019-20891","markdown":"https://insights.sbomify.com/CVE-2019-20891/index.md","name":"CVE-2019-20891","record":{"aliases":["GHSA-rcmf-88p4-9wrg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WooCommerce plugin","requires_auth":"none","summary":"Attackers can inject malicious scripts via CSV imports, leading to stored XSS and potential account takeover in WooCommerce installations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"woocommerce","vendor":"woocommerce"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site request forgery (CSRF) issue with resultant stored cross-site scripting (XSS) via includes/admin/importers/class-wc-product-csv-importer-controller.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WooCommerce Cross-Site Request Forgery (CSRF)","id":"CVE-2019-20891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Use after free in n/a","id":"CVE-2019-20892"},"packages":[{"ecosystem":"Packagist","fixed":["3.6.5"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":null,"source":"GHSA-rcmf-88p4-9wrg"},{"ecosystem":"Packagist","fixed":["3.6.5"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":"pkg:composer/woocommerce/woocommerce","source":"GHSA-rcmf-88p4-9wrg"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2019-20890"},"products":["n/a"],"published":"2020-06-19","related":[{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2017-18356","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":8.1,"headline":"Path traversal in n/a","id":"CVE-2018-20714","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":6.1,"headline":"WooCommerce \u003c= 9.4.2 - PostMessage-Based Cross-Site Scripting","id":"CVE-2025-5062","kev_date_added":null,"published":"2025-05-22"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-9168","kev_date_added":null,"published":"2019-02-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2015-2329","kev_date_added":null,"published":"2018-02-08"},{"cvss_score":5.9,"headline":"WordPress Product page shipping calculator for WooCommerce Plugin \u003c= 1.3.25 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-32575","kev_date_added":null,"published":"2023-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via CSV imports, leading to stored XSS and potential account takeover in WooCommerce installations.","url":"https://insights.sbomify.com/CVE-2019-20891/"}