# CVE-2019-20891: WooCommerce Cross-Site Request Forgery (CSRF)

> Attackers can inject malicious scripts via CSV imports, leading to stored XSS and potential account takeover in WooCommerce installations.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jun 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rcmf-88p4-9wrg

## What is CVE-2019-20891?

CVE-2019-20891 is a high-severity cross-site scripting vulnerability in n/a, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site request forgery (CSRF) issue with resultant stored cross-site scripting (XSS) via includes/admin/importers/class-wc-product-csv-importer-controller.php.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-20891?

2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `woocommerce/woocommerce` | Packagist | All versions | 3.6.5 |
| `woocommerce/woocommerce` | Packagist | All versions | 3.6.5 |

Products: Woocommerce Woocommerce.

## How do I fix CVE-2019-20891?

Upgrade woocommerce/woocommerce to 3.6.5 or later.

## Is CVE-2019-20891 being exploited?

There is no known exploitation of CVE-2019-20891 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-18356](https://insights.sbomify.com/CVE-2017-18356/): Code injection in n/a (high 8.8)
- [CVE-2018-20714](https://insights.sbomify.com/CVE-2018-20714/): Path traversal in n/a (high 8.1)
- [CVE-2025-5062](https://insights.sbomify.com/CVE-2025-5062/): WooCommerce <= 9.4.2 - PostMessage-Based Cross-Site Scripting (medium 6.1)
- [CVE-2019-9168](https://insights.sbomify.com/CVE-2019-9168/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2015-2329](https://insights.sbomify.com/CVE-2015-2329/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-20891 and fix it if it is affected.

What it is: CVE-2019-20891 is a high-severity cross-site scripting vulnerability in n/a, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-20891 in the wild and no public exploit code.

Affected packages and fixed versions:
- woocommerce/woocommerce (Packagist): affected all versions; fixed in 3.6.5
- woocommerce/woocommerce (Packagist): affected all versions; fixed in 3.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-20891/ (Markdown: https://insights.sbomify.com/CVE-2019-20891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-20891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-20891
- OSV: https://osv.dev/vulnerability/CVE-2019-20891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-20891/
Summaries are generated and may contain mistakes; the official description above is the record.
