CVE-2019-20920 Arbitrary Code Execution in Handlebars

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2019-20920?

CVE-2019-20920 is a high-severity vulnerability in n/a, published on 30 Sep 2020.

Official description

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).

Weakness: CWE-94

Which versions are affected by CVE-2019-20920?

4 open source packages ship an affected version, including handlebars. It affects 1 product.

PackageAffectedFixed in
handlebars npmAll versions3.0.8
handlebars npmAll versions3.0.8
handlebars npmFrom 4.0.04.5.3
handlebars npmFrom 4.0.04.5.3

Products include Handlebarsjs Handlebars.

How do I fix CVE-2019-20920?

Upgrade handlebars to a fixed version for your release line: 3.0.8 or 4.5.3.

Is CVE-2019-20920 being exploited?

There is no known exploitation of CVE-2019-20920 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2019-20920, GHSA-3cqr-58rm-57f8, MINI-446m-rr6q-r26p, ROOT-APP-NPM-CVE-2019-20920, SNYK-JS-HANDLEBARS-534478, UBUNTU-CVE-2019-20920.

Is CVE-2019-20920 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free